<!DOCTYPE html><html ng-strict-di><head><script type="text/javascript">(function(d) {var config={kitId:'xjd1kby',scriptTimeout:10000}, h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement("script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";tk.src='//use.typekit.net/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)})(document);</script><link href="http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" rel="canonical"><link href="/css/10.21.0/main.min.css" rel="stylesheet" type="text/css"><link rel="icon" href="/images/favicon.png" type="image/png" sizes="16x16"><link rel="icon" href="/images/favicon.ico" type="image/x-icon"><link rel="shortcut icon" href="/images/favicon.ico" type="image/x-icon"><script>var _sf_startpt = (new Date()).getTime(); var fuse = {};var switchTo5x=true;fuse.pageContext = {"title":"'Spider-Man: Homecoming Trailers': See Donald Glover Finally Make a Cameo","pageTitle":"'Spider-Man: Homecoming Trailers': See Tony Stark Go Into Dad Mode (& Donald Glover Makes a Cameo)","shareTitle":"'Spider-Man: Homecoming Trailers': See Donald Glover Finally Make a Cameo","description":"The two new 'Spider-Man: Homecoming' trailers feature a new Spidey suit, first glimpses at Donald Glover and much more. Watch them here.","keywords":"","twitterTracking":"","type":"article","contentType":"article","contributors":"Bianca Gracie","image":"/image/59259c6b459765c40900000c/560/292/social/spider-man-trailer-still-1.jpg","url":"http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover","path":"2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover","tags":["franchise:movies","franchise:news","franchise:comics","miscellaneous:marvel","artist:childish-gambino","artist:zendaya","genre:r-b","genre:pop"],"opengraph":{},"published":"2017-05-24T14:51:00.000Z","lastModified":"2017-05-24T14:58:13.685Z","noIndexNoFollow":false,"showNewsletterSignup":false};</script><!-- Respond.js for IE8 support of HTML5 elements and media queries -->
<!--[if lt IE 9]><script src="/js/lib/10.21.0/respond.min.js" type="text/javascript"></script><![endif]--><!-- Start of Taboola Tags: do not remove--><script type="text/javascript">window._tfa = window._tfa || []; _tfa.push({notify:"action", name: 'page_view'});</script><script src="//cdn.taboola.com/libtrc/fusetv-sc/tfa.js"></script><!-- End of Taboola Tags: do not remove--><link href="//feeds.feedburner.com/fuse/latest" title="Latest from Fuse" rel="alternate" type="application/rss+xml"><title>'Spider-Man: Homecoming Trailers': See Tony Stark Go Into Dad Mode (&amp; Donald Glover Makes a Cameo) - Fuse</title><meta charset="utf-8"><meta http-equiv="content-type" content="text/html;charset=utf-8"><meta name="viewport" content="width=device-width,minimum-scale=1.0, maximum-scale=1.0, initial-scale=1.0"><meta name="description" content="The two new 'Spider-Man: Homecoming' trailers feature a new Spidey suit, first glimpses at Donald Glover and much more. Watch them here."><meta name="keywords" content=""><meta property="fb:pages" content="10262075277"><meta property="og:site_name" content="Fuse"><meta property="og:title" content="'Spider-Man: Homecoming Trailers': See Donald Glover Finally Make a Cameo"><meta property="og:description" content="The two new 'Spider-Man: Homecoming' trailers feature a new Spidey suit, first glimpses at Donald Glover and much more. Watch them here."><meta property="og:image" content="http://www.fuse.tv/image/59259c6b459765c40900000c/560/292/social/spider-man-trailer-still-1.jpg"><meta property="og:url" content="http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover"><meta property="og:type" content="article"><meta property="fb:app_id" content="1272603569472546"><meta property="fb:admins" content="741460474"><meta property="fw:profilePath" content="fuse_live"><meta property="fw:server" content="freewheel-live.fuse.tv/ad/g/1"><meta property="fw:networkId" content="190200"><meta property="fw:adManagerServer" content="adm.fwmrm.net"></head><body itemscope itemtype="//schema.org/WebPage" class="article"><div class="container jp-container"><div class="row"><div class="col-span-24"><div class="header-ad"><div class="advert-outter"><div id="advert-leaderboard" class="advert-inner"></div></div></div></div></div></div><header itemscope itemtype="//schema.org/WPHeader" class="main-header"><div class="main-nav-container"><div class="container"><div class="row"><h1 data-section="header|logo" class="col-span-3 logo-container">FUSE<a href="/" data-track="item" class="icon-fuse-link"><img src="/images/fuse_logo.png" class="icon-fuse_logo"></a></h1><div class="col-span-15 nav-holder"><div class="row"><nav class="col-span-24"><ul data-section="header|nav" class="nav nav-main hidden-phone"><li class="nav-shows"><a href="/shows" data-track="item" data-track-title="shows" class="link-text">Shows</a></li><li class="divider"></li><li class="nav-latest"><a href="/latest" data-track="item" data-track-title="latest" class="link-text">Latest</a></li><li class="divider"></li><li class="nav-events"><a href="/events" data-track="item" data-track-title="events" class="link-text">Events</a></li><li class="divider"></li><li class="nav-schedule"><a href="/schedule" data-track="item" data-track-title="tv schedule" class="link-text">Schedule</a></li></ul></nav></div></div><nav class="search-social-container"><ul class="search-social-nav"><li class="search-li"><a href="#" id="searchButton" class="icon-search"></a></li><li class="divider"></li><li class="search-li"><a href="#" id="closeMobileMenu" class="icon-close_x close-mobile-menu"></a></li><li class="search-li"><a href="#" id="burgerButton" class="visible-phone icon-menu"></a></li><li class="search-li"><a href="#" id="moreButton" class="icon-three_dots"></a></li></ul><div id="searchBoxContainer" class="search-box"><fieldset id="search-box"><button type="button" for="fuse-search-field" class="search-label"><div class="icon-search icon-desktop"><i></i></div></button><label for="fuse-search-field" class="search-close-label"><div class="icon-close_x"><i></i></div></label><input type="text" id="fuse-search-field" name="q" placeholder="" class="search-input"></fieldset></div></nav><a id="jump" href="http://www.fm.tv" data-track="fusefm" data-track-title="fusefm" class="jump-to-fm visible-desktop"><span class="visible-desktop icon-fusefm_logo"><i></i></span><span class="visible-desktop jump-to-text">Jump to FM.tv</span></a></div></div></div><div class="container"><div class="more-arrow hidden"></div><div id="nav-wrapper" class="more-box"><ul data-section="header|nav" class="nav nav-main visible-phone"><li class="nav-shows"><a href="/shows" data-track="item" data-track-title="shows" class="link-text">Shows</a></li><li class="divider"></li><li class="nav-latest"><a href="/latest" data-track="item" data-track-title="latest" class="link-text">Latest</a></li><li class="divider"></li><li class="nav-events"><a href="/events" data-track="item" data-track-title="events" class="link-text">Events</a></li><li class="divider"></li><li class="nav-schedule"><a href="/schedule" data-track="item" data-track-title="tv schedule" class="link-text">Schedule</a></li><li class="divider"></li></ul><div class="col-span-17 nav-social"><a href="//facebook.com/Fuse" target="_blank" data-track="item" data-track-title="facebook" class="nav-social__icon nav-social__icon--facebook"><i></i></a><a href="//twitter.com/fusetv" target="_blank" data-track="item" data-track-title="twitter" class="nav-social__icon nav-social__icon--twitter"><i></i></a><a href="//youtube.com/fuse" target="_blank" data-track="item" data-track-title="youtube" class="nav-social__icon nav-social__icon--youtube"><i></i></a><a href="//instagram.com/fusetv" target="_blank" data-track="item" data-track-title="youtube" class="nav-social__icon nav-social__icon--instagram"><i></i></a></div><nav class="col-span-24"><div class="divider"></div><ul class="ext-nav"><li class="ext-nav-li"><a href="/privacy-policy" data-track="item" class="ext-nav-link">Privacy Policy</a></li><li class="ext-divider">-</li><li class="ext-nav-li"><a href="/terms-of-use" data-track="item" class="ext-nav-link">Terms of Use</a></li><li class="ext-divider">-</li><li class="ext-nav-li"><a href="/closed-captioning" data-track="item" class="ext-nav-link">Closed Captioning</a></li><li class="ext-divider"></li><li class="ext-nav-li"><a href="/about-fuse" data-track="item" class="ext-nav-link">About Fuse</a></li><li class="ext-divider">-</li><li class="ext-nav-li"><a href="/press" data-track="item" class="ext-nav-link">Press</a></li></ul></nav><div class="col-span-24 copyright">&copy; 2017 FUSE, LLC. ALL RIGHTS RESERVED.</div></div><a id="fmButton" href="http://www.fm.tv" data-track="fusefm" data-track-title="fusefm" class="jump-to-fm hidden-desktop"><span class="icon-fusefm_logo"><i></i></span><span class="jump-to-text">Jump to FM.tv</span></a></div><div class="row visible-desktop topics"><div class="container"><ul data-section="header|topic" class="nav-topic-list"><li class="nav-topic-li"><strong class="nav-topic-strong">Don't Miss:</strong></li><li class="nav-topic-li"><a href="/shows/now-boarding" data-track="item" class="nav-topic-link">Now Boarding</a></li><li class="divider"></li><li class="nav-topic-li"><a href="/shows/future-asian-pacific-history-month" data-track="item" class="nav-topic-link">Future Asian &amp; Pacific History</a></li><li class="divider"></li><li class="nav-topic-li"><a href="/shows/fluffys-food-adventures" data-track="item" class="nav-topic-link">Fluffy's Food Adventures</a></li><li class="divider"></li><li class="nav-topic-li"><a href="/shows/right-footed" data-track="item" class="nav-topic-link">Right Footed</a></li></ul></div></div></header><div class="background-image-container background-image-container--article"></div><div id="menu-overlay" class="menu-overlay"></div><div class="container main-container article two-columns-layout"><div class="two-columns-styler hidden-tablet hidden-phone"><div class="col-span-17">&nbsp;</div><div class="col-span-7">&nbsp;</div></div><div class="row two-columns"><div itemscope itemtype="http://schema.org/Article" class="article-container col-span-17"><div class="content-header"><div class="rubric">New Trailer</div><h1 itemprop="name" class="article-title">'Spider-Man: Homecoming Trailers': See Donald Glover Finally Make a Cameo</h1><div itemprop="description" class="dek">There's also the first glimpse at Zendaya's character!</div></div><div class="content-sub-header">   <div data-section="center|contributors" class="contributors-info"><ul class="contributors-list"><li class="contributors-item"><a href="/contributors/bianca-gracie" rel="author" data-track="contributor" data-track-title="bianca-gracie" class="contributors-link"><img src="/image/56c79ef5d6899aaa40000046/30/30/crop/bianca-gracie-contributor-photo-thumbnail.jpg" title="Bianca Gracie" alt="Bianca Gracie" width="30" height="30" class="contributor-thumbnail"/><span>Bianca Gracie</span></a></li></ul><span datetime="2017-05-24T02:51:00+00:00" itemprop="datePublished" class="published">May 24, 2017</span></div><div class="social-container top"><div data-section="center|share" class="share-container"> <div id="result"></div><ul class="share-list"><li class="item"><a data-track-title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" target="_blank" class="item-container share-tracker js-share-btn__facebook"><span class="icon icon-facebook"></span><span class="text">share</span></a><span class="bubble-count fb-count">0</span></li><li class="item"><a data-track-title="twitter" href="https://twitter.com/intent/tweet?text=&amp;via=fusetv&amp;url=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" target="_blank" class="item-container share-tracker js-share-btn__twitter"><span class="icon icon-twitter"></span><span class="text">tweet</span></a></li><li class="item"><a data-track-title="tumblr" href="http://www.tumblr.com/share/link?url=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" target="_blank" class="item-container share-tracker last js-share-btn__tumblr"><span class="icon icon-tumblr"></span><span class="text">share</span></a><span class="bubble-count tumb-count">0</span></li><li class="item more-share icon-plus"></li></ul><ul class="more-share-items">&nbsp;<li class="item"><a data-track-title="reddit" href="http://www.reddit.com/submit?url=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover&amp;title=" target="_blank" class="item-container share-tracker js-share-btn__reddit"><span class="icon icon-redit_face"></span><span class="text">share</span></a><span class="bubble-count red-count">0</span></li><li class="item"><a data-track-title="google" href="https://plus.google.com/share?url=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" target="_blank" class="item-container share-tracker js-share-btn__gplus"><span class="icon icon-google"></span><span class="text">share</span></a><span class="bubble-count glg-count">0</span></li><li class="item"><a data-track-title="pinterest" href="http://pinterest.com/pin/create/button/?url=&quot;http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover&amp;media=http://www.fuse.tv/image/59259c6b459765c40900000c/560/292/social/spider-man-trailer-still-1.jpg&amp;description=&quot;" target="_blank" class="item-container share-tracker js-share-btn__pinterest"><span class="icon icon-pinterest"></span><span class="text">pin it</span></a><span class="bubble-count ptr-count">0</span></li></ul></div></div><div class="social-container side"><div data-section="left|share" class="share-side"><div class="share-side-buttons visible-desktop"><div id="result"></div><ul class="share-list"><li class="item"><a data-track-title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" target="_blank" class="item-container share-tracker js-share-btn__facebook"><span class="icon icon-facebook"></span><span class="text">share</span></a><span class="bubble-count fb-count">0</span></li><li class="item"><a data-track-title="twitter" href="https://twitter.com/intent/tweet?text=&amp;via=fusetv&amp;url=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" target="_blank" class="item-container share-tracker js-share-btn__twitter"><span class="icon icon-twitter"></span><span class="text">tweet</span></a></li><li class="item"><a data-track-title="tumblr" href="http://www.tumblr.com/share/link?url=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" target="_blank" class="item-container share-tracker last js-share-btn__tumblr"><span class="icon icon-tumblr"></span><span class="text">share</span></a><span class="bubble-count tumb-count">0</span></li><li class="item more-share icon-plus"></li></ul><ul class="more-share-items">&nbsp;<li class="item"><a data-track-title="reddit" href="http://www.reddit.com/submit?url=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover&amp;title=" target="_blank" class="item-container share-tracker js-share-btn__reddit"><span class="icon icon-redit_face"></span><span class="text">share</span></a><span class="bubble-count red-count">0</span></li><li class="item"><a data-track-title="google" href="https://plus.google.com/share?url=http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" target="_blank" class="item-container share-tracker js-share-btn__gplus"><span class="icon icon-google"></span><span class="text">share</span></a><span class="bubble-count glg-count">0</span></li><li class="item"><a data-track-title="pinterest" href="http://pinterest.com/pin/create/button/?url=&quot;http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover&amp;media=http://www.fuse.tv/image/59259c6b459765c40900000c/560/292/social/spider-man-trailer-still-1.jpg&amp;description=&quot;" target="_blank" class="item-container share-tracker js-share-btn__pinterest"><span class="icon icon-pinterest"></span><span class="text">pin it</span></a><span class="bubble-count ptr-count">0</span></li></ul></div></div></div></div><div class="content-container"><div itemprop="articleBody" class="article-body"><div class="media embed-video-container"><iframe type="text/html" src="//www.youtube.com/embed/U0D3AOldjMU?enablejsapi=1" frameborder="0" allowfullscreen="yes"></iframe></div><div class="text"><p>Marvel is keeping the anticipation high for&nbsp;<a href="http://www.fuse.tv/2017/03/spider-man-homecoming-trailer-vulture-iron-man"><em>Spider-Man: Homecoming</em></a><em>, </em>as they dropped not one—but <em>two </em>new trailers that are filled with nonstop (and kind of awkward) action. We get to see even more of Peter Parker's (a.k.a. Tom Holland) new flashy suit, courtesy of Iron Man/Tony Stark (Robert Downey Jr.). The high-profile businessman usually has a sarcastic, cold heart but it's absolutely adorable seeing him being a father figure to young Spidey.</p></div><div class="media embed-video-container"><iframe type="text/html" src="//www.youtube.com/embed/xbQdPBiF3Co?enablejsapi=1" frameborder="0" allowfullscreen="yes"></iframe></div><div class="text"><p>There's also glimpses (finally!) into&nbsp;<a href="http://www.fuse.tv/2016/06/donald-glover-spider-man-homecoming">Donald Glover's character</a> as well as&nbsp;<a href="http://www.fuse.tv/artists/zendaya">Zendaya</a>, who plays Parker's&nbsp;<a href="http://www.fuse.tv/2016/03/zendaya-spider-man-reboot">high school classmate Michelle</a>. And of course, the big, bad and bulky Vulture (Michael Keaton) makes an appearance as he tries to take down Spider-Man.</p></div><div class="related-content-plug"><div><span class="more">More:</span><span><a href="/2017/01/2017-movies-preview-biggest-most-anticipated"><span>The 20 Most Anticipated Movies of 2017</span></a></span></div></div><div class="text"><p>The new&nbsp;<em>Spider-Man: Homecoming </em>trailers follows&nbsp;<a href="http://www.fuse.tv/2016/12/spider-man-homecoming-official-trailer-tom-holland-iron-man">last December's debut clip</a> and the&nbsp;<a href="http://www.fuse.tv/2017/03/spider-man-homecoming-trailer-vulture-iron-man">latest trailer in March.</a> The movie, directed by Jon Watts, swings into theaters on July 7. It also stars Jon Favreau reprising his role as Happy Hogan, Tyne Daly, Marisa Tomei as Aunt May and Jacob Batalon&nbsp;as Parker's best friend Ned. Next, watch Marvel editor-in-chief Axel Alonso preview the ways the comic-book empire will sync up with its movie and television offerings in 2017:</p></div><div class="embed-video-container the-platform-video-player"><iframe src="//player.theplatform.com/p/_r8IPC/7GVf4xQmo45D/select/media/hNUdOSEPPiDc?form=html&amp;videoWidth=817&amp;videoHeight=460" width="817" height="460" frameBorder="0" seamless="seamless" allowFullScreen="allowFullScreen" class="theplatform"></iframe></div></div></div><div data-section="center|tags" class="compnt compnt-tags"><div class="compnt-content"><strong class="tags-title">Tags:&nbsp;</strong><a href="/tags/movies" data-track="item" rel="tag" class="tag-link">Movies</a><span>,&nbsp;</span><a href="/tags/news" data-track="item" rel="tag" class="tag-link">News</a><span>,&nbsp;</span><a href="/tags/comics" data-track="item" rel="tag" class="tag-link">Comics</a><span>,&nbsp;</span><a href="/tags/marvel" data-track="item" rel="tag" class="tag-link">Marvel</a><span>,&nbsp;</span><a href="/artists/childish-gambino" data-track="item" rel="tag" class="tag-link">Childish Gambino</a><span>,&nbsp;</span><a href="/artists/zendaya" data-track="item" rel="tag" class="tag-link">Zendaya</a><span>,&nbsp;</span><a href="/tags/r-b" data-track="item" rel="tag" class="tag-link">R&amp;B</a><span>,&nbsp;</span><a href="/tags/pop" data-track="item" rel="tag" class="tag-link">Pop</a></div></div><div data-section="center|prev-next" class="compnt compnt-prev-next clearfix"><div class="prev"><a href="/galleries/2017/04/asian-pacific-history-month-faces-of-future-asian-pacific-history" data-track="prev-arrow" class="icon-arrow icon-arrow_left"></a><p class="text"><a href="/galleries/2017/04/asian-pacific-history-month-faces-of-future-asian-pacific-history" data-track="prev-title" class="link"> <span class="nav-name">PREVIOUS</span><span class="nav-text">Photos: The Faces of Future Asian &amp; Pacific History</span></a></p></div><div class="next"><a href="/2017/05/ashley-tisdale-lucas-grabeel-what-ive-been-looking-for-high-school-musical-reunion-performance" data-track="next-arrow" class="icon-arrow icon-arrow_right"></a><p class="text"><a href="/2017/05/ashley-tisdale-lucas-grabeel-what-ive-been-looking-for-high-school-musical-reunion-performance" data-track="next-title" class="link"> <span class="nav-name">NEXT </span><span class="nav-text">Ashley Tisdale &amp; Lucas Grabeel Reunite to Sing 'HSM' Duet</span></a></p></div></div><div class="row"><div class="col-span-26"><div data-section="center|recommended" class="compnt module compnt-zergnet"><div class="compnt-content"><div id="zergnet-widget-46079" class="row"></div><div id="zergnet-widget-46081" class="row"></div></div></div></div></div><div class="row visible-phone"><div id="ad_articleBottom_phone" class="ad-bottom-phone"></div></div><div class="user-comments"><div class="compnt module"><div class="compnt-head"><h3 class="title border">User Comments</h3></div><div data-width="716" data-href="http://www.fuse.tv/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" class="fb-comments"></div></div><div id="ad_articleBottom_tablet" class="visible-tablet ad-bottom-tablet"></div></div></div><div itemscope itemtype="http://schema.org/WPSideBar" class="col-span-7 hidden-tablet hidden-phone"><div class="ad text-center"><span style="margin:0px auto;overflow:hidden;" id="ad_articleTop" class="advert _fwph"><form id="_fw_form_ad_articleTop" style="display:none;"><input type="hidden" name="_fw_input_ad_articleTop" id="_fw_input_ad_articleTop" value="ptgt=s&amp;w=300&amp;h=250&amp;slid=ad_articleTop&amp;cd=300,250|300,600&amp;slau="/></form><span id="_fw_container_ad_articleTop"></span></span><span class="ad">Advertisement</span></div><div data-limit="5" data-section="right|popular" class="compnt module compnt-popular trending-sidebar"><div class="compnt-head"><h3 class="title-sidebar">Most Popular</h3></div><ul class="unstyled"></ul></div><div data-section="right|photo-day" class="compnt module compnt-photo-of-the-day"><div class="compnt-head"><h3>Photo of the day</h3></div><a href="/2017/05/celebrity-photos-may-2017" data-track="image"><img src="/image/5924a17924d6751145000091/316/211/crop/photo-of-the-day-big-freedia-for-meundies.jpg" title="Photo of the Day, Big Freedia for MeUndies" width="316" height="211"/>                               </a><div class="compnt-content"><a href="/2017/05/celebrity-photos-may-2017" data-track="title"><h2>May 23: Freedia's MeUndies</h2></a><p><a href="http://www.fuse.tv/artists/big-freedia">Big Freedia</a> is stripping down...for a good cause! The&nbsp;<a href="http://www.fuse.tv/shows/big-freedia">'Big Freedia Bounces Back'</a> star is a model for MeUndie's Celebrate Yourself pride campaign. Alongside singer-actress Hayley Kiyoko, Olympic skier Gus Kenworthy, blogger B Scott and more, the queen of bounce is seen rocking a pair where every sale will donate $1 to the Los Angeles LGBT Center.&nbsp;<a href="https://www.meundies.com/t/category/underwear?pc=cel" target="_blank">Check em out!</a></p></div><div class="compnt-foot"><a href="/2017/05/celebrity-photos-may-2017" data-track="more" class="square-btn">More Photos</a></div></div><div class="ad text-center"><span style="margin:0px auto;overflow:hidden;" id="ad_articleBottom" class="advert _fwph"><form id="_fw_form_ad_articleBottom" style="display:none;"><input type="hidden" name="_fw_input_ad_articleBottom" id="_fw_input_ad_articleBottom" value="ptgt=s&amp;w=300&amp;h=250&amp;slid=ad_articleBottom&amp;cd=300,250&amp;slau=300x250bottom"/></form><span id="_fw_container_ad_articleBottom"></span></span><span class="ad">Advertisement</span></div></div></div><div id="latest" class="row"><div class="col-span-24 latest-block latest-block-ipad"><div data-feature-filter="genre" data-section="bottom|latest" class="compnt section compnt-latest"><div class="compnt-head "><h3 class="module-subtitle">The Latest</h3></div><div class="compnt-content"><div class="latest-container"><div class="col-span-6 feature-quarter"><a href="/2017/05/the-weeknd-tell-your-friends-extended-remix-drake-kanye" data-track="item" class="img"><img src="/image/5925a6befe16a6c309000018/268/179/crop/the-weeknd-puts-drake-kanye-west-more-on-tell-your-friends-remix-still.jpg" title="The Weeknd Puts Drake, Kanye West &amp; More on 'Tell Your Friends' Remix - still" width="268" height="179" class="stream-image"/><span class="rubric">Hot Song</span></a><div class="title-description"><a href="/2017/05/the-weeknd-tell-your-friends-extended-remix-drake-kanye" data-track="item"><h2 class="stream-title">The Weeknd Puts Drake, Kanye, Nas &amp; More on Mega-Remix</h2></a><div class="date-user gray-letters"><a href="/contributors/zach-dionne" rel="author" data-track="contributor" class="user-link"><span>Zach Dionne</span><span>&nbsp;/ May 24, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/2017/05/ashley-tisdale-lucas-grabeel-what-ive-been-looking-for-high-school-musical-reunion-performance" data-track="item" class="img"><img src="/image/5925a3e39e0e776809000012/268/179/crop/what-ive-been-looking-for-ft-lucas-grabeel-music-sessions-ashley-tisdale-still.jpg" title="What I’ve Been Looking For ft. Lucas Grabeel | Music Sessions | Ashley Tisdale - still" width="268" height="179" class="stream-image"/><span class="rubric">Live Performance</span></a><div class="title-description"><a href="/2017/05/ashley-tisdale-lucas-grabeel-what-ive-been-looking-for-high-school-musical-reunion-performance" data-track="item"><h2 class="stream-title">Ashley Tisdale &amp; Lucas Grabeel Reunite to Sing 'HSM' Duet</h2></a><div class="date-user gray-letters"><a href="/contributors/jeff-benjamin" rel="author" data-track="contributor" class="user-link"><span>Jeff Benjamin</span><span>&nbsp;/ May 24, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" data-track="item" class="img"><img src="/image/59259c6b459765c40900000c/268/179/crop/spiderman-homecoming-trailer-3-still.jpg" title="Spider-Man: Homecoming - Trailer 3 - still" width="268" height="179" class="stream-image"/><span class="rubric">New Trailer</span></a><div class="title-description"><a href="/2017/05/new-spider-man-homecoming-trailers-tony-stark-vulture-donald-glover" data-track="item"><h2 class="stream-title">Watch Two New 'Spider-Man: Homecoming' Trailers (One Has Donald Glover!)</h2></a><div class="date-user gray-letters"><a href="/contributors/bianca-gracie" rel="author" data-track="contributor" class="user-link"><span>Bianca Gracie</span><span>&nbsp;/ May 24, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/galleries/2017/04/asian-pacific-history-month-faces-of-future-asian-pacific-history" data-track="item" class="img"><img src="/image/590a0f3a40ef2172380000cf/268/179/crop/homepage-future-asian-pacific-history-month-gallery-split.jpg" title="Homepage - Future Asian &amp; Pacific History Month Gallery - split" alt="Riz Ahemd, Dinah Jane of Fifth Harmony, Constance Wu" width="268" height="179" class="stream-image"/><span class="rubric">Gallery</span></a><div class="title-description"><a href="/galleries/2017/04/asian-pacific-history-month-faces-of-future-asian-pacific-history" data-track="item"><h2 class="stream-title">Photos: The Faces of Future Asian &amp; Pacific History</h2></a><div class="date-user gray-letters"><a href="/contributors/fuse-staff" rel="author" data-track="contributor" class="user-link"><span>Fuse Staff</span><span>&nbsp;/ May 24, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/2017/05/dumbfoundead-rapper-future-asian-pacific-history-month" data-track="item" class="img"><img src="/image/591a1d0aeccedee458000030/268/179/crop/future-asian-pacific-history-month-dumbfoundead.jpg" title="Future Asian &amp; Pacific History Month - Dumbfoundead" width="268" height="179" class="stream-image"/><span class="rubric">Spotlight</span></a><div class="title-description"><a href="/2017/05/dumbfoundead-rapper-future-asian-pacific-history-month" data-track="item"><h2 class="stream-title">Future Asian &amp; Pacific History Month: Dumbfoundead</h2></a><div class="date-user gray-letters"><a href="/contributors/tina-xu" rel="author" data-track="contributor" class="user-link"><span>Tina Xu</span><span>&nbsp;/ May 24, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/2017/05/celebrity-photos-may-2017" data-track="item" class="img"><img src="/image/5924a17924d6751145000091/268/179/crop/photo-of-the-day-big-freedia-for-meundies.jpg" title="Photo of the Day, Big Freedia for MeUndies" width="268" height="179" class="stream-image"/><span class="rubric">May 2017</span></a><div class="title-description"><a href="/2017/05/celebrity-photos-may-2017" data-track="item"><h2 class="stream-title">Photo of the Day: Big Freedia Strips Down For A Good Cause</h2></a><div class="date-user gray-letters"><a href="/contributors/fuse-staff" rel="author" data-track="contributor" class="user-link"><span>Fuse Staff</span><span>&nbsp;/ May 23, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/2017/05/ariana-grande-suspends-dangerous-woman-tour-manchester-attack" data-track="item" class="img"><img src="/image/5924a13a9ea568247900004d/268/179/crop/ariana-grande-dangerous-woman-tour-opener-phoenix-2017.jpg" title="Ariana Grande &quot;Dangerous Woman&quot; Tour Opener - Phoenix 2017" alt="PHOENIX, AZ - FEBRUARY 03:  (EXCLUSIVE COVERAGE)  Ariana Grande performs on stage during the &quot;Dangerous Woman&quot; Tour Opener at" width="268" height="179" class="stream-image"/><span class="rubric">News</span></a><div class="title-description"><a href="/2017/05/ariana-grande-suspends-dangerous-woman-tour-manchester-attack" data-track="item"><h2 class="stream-title">Ariana Grande Suspends Tour After Manchester Attack</h2></a><div class="date-user gray-letters"><a href="/contributors/jeff-benjamin" rel="author" data-track="contributor" class="user-link"><span>Jeff Benjamin</span><span>&nbsp;/ May 23, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/2017/05/sophie-b-hawkins-interview-then-now-new-album-lgbtq-pride-month" data-track="item" class="img"><img src="/image/592351a1f59e5c2e5e00003e/268/179/crop/sophie-b-hawkins-then-now-1992-2017-split.jpg" title="Sophie B. Hawkins - Then &amp; Now, 1992 + 2017 - split" width="268" height="179" class="stream-image"/><span class="rubric">Interview</span></a><div class="title-description"><a href="/2017/05/sophie-b-hawkins-interview-then-now-new-album-lgbtq-pride-month" data-track="item"><h2 class="stream-title">Then &amp; Now: Sophie B. Hawkins Talks Her '90s Hits &amp; New Album</h2></a><div class="date-user gray-letters"><a href="/contributors/bianca-gracie" rel="author" data-track="contributor" class="user-link"><span>Bianca Gracie</span><span>&nbsp;/ May 23, 2017</span></a></div></div></div></div></div><div class="compnt-foot"><div class="load-img hide-all"></div><a href="#" data-stream="/content/stream/latest?page=2" data-append-to=".latest-container" data-item-selector=".feature-quarter" data-limit="8" data-track="more" class="square-btn load-stream">Load More</a></div></div></div></div></div><footer itemscope itemtype="http://schema.org/WPFooter" class="hidden-phone hidden-tablet main-footer"><div class="container"><div class="footer-links hidden-phone"><div class="col-span-3"><a href="/" data-track="item" class="icon-fuse-link"><img src="/images/fuse_logo.png" class="icon-fuse_logo"></a></div><div class="col-span-17"><div class="row"><ul data-section="footer|nav" class="nav nav-main"><li class="nav-shows"><a href="/shows" data-track="item" data-track-title="shows" class="link-text">Shows</a></li><li class="divider"></li><li class="nav-latest"><a href="/latest" data-track="item" data-track-title="latest" class="link-text">Latest</a></li><li class="divider"></li><li class="nav-events"><a href="/events" data-track="item" data-track-title="events" class="link-text">Events</a></li><li class="divider"></li><li class="nav-schedule"><a href="/schedule" data-track="item" data-track-title="tv schedule" class="link-text">Schedule</a></li></ul></div></div><div class="col-span-4"><div data-track="footer|social" class="compnt right"><div class="compnt-content nav-social"><a href="//facebook.com/Fuse" target="_blank" data-track="item" data-track-title="facebook" class="nav-social__icon nav-social__icon--facebook"><i></i></a><a href="//twitter.com/fusetv" target="_blank" data-track="item" data-track-title="twitter" class="nav-social__icon nav-social__icon--twitter"><i></i></a><a href="//youtube.com/fuse" target="_blank" data-track="item" data-track-title="youtube" class="nav-social__icon nav-social__icon--youtube"><i></i></a><a href="//instagram.com/fusetv" target="_blank" data-track="item" data-track-title="youtube" class="nav-social__icon nav-social__icon--instagram"><i></i></a></div></div></div></div><div class="row"><div class="col-span-24"><ul class="ext-nav"><li class="ext-nav-li"><a href="/privacy-policy" data-track="item" class="ext-nav-link">Privacy Policy</a></li><li class="divider"></li><li class="ext-nav-li"><a href="/terms-of-use" data-track="item" class="ext-nav-link">Terms of Use</a></li><li class="divider"></li><li class="ext-nav-li"><a href="/closed-captioning" data-track="item" class="ext-nav-link">Closed Captioning</a></li><li class="divider"></li><li class="ext-nav-li"><a href="/about-fuse" data-track="item" class="ext-nav-link">About Fuse</a></li><li class="divider"></li><li class="ext-nav-li"><a href="/press" data-track="item" class="ext-nav-link">Press</a></li></ul></div><div class="col-span-24 copyright">&copy; 2017 FUSE, LLC. ALL RIGHTS RESERVED.</div></div></div></footer><div id="fb-root"></div><div id="BF_WIDGET_1"></div><script src="/js/10.21.0/base.min.js"></script><script src="/js/10.21.0/fuse.ui.tvschedule.min.js"></script><script>window.fbAsyncInit = function(){FB.init({appId:'1272603569472546',version:'v2.8',cookie:true,status:true,xfbml:true,channelUrl:'//www.fuse.tv/channel.html'});fuse.analytics.trackFacebook();if(fuse.fbAsyncInit){fuse.fbAsyncInit();}};</script><script>(function(d, s, id){var js, fjs = d.getElementsByTagName(s)[0];if (d.getElementById(id)) {return;}js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/sdk.js";fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));</script><script src="//platform.instagram.com/en_US/embeds.js" async="" defer=""></script><!-- SiteCatalyst code version: H.25.2. Copyright 1996-2012 Adobe, Inc. All Rights Reserved More info available at http://www.omniture.com--><script src="/js/10.21.0/fuse.tracking.min.js"></script><script>var s_code = null;fuse.omniture.initPageData();if (fuse.omniture.isTrackPageViewAutomaticallyEnable()){s_code=s.t();}else{s=fuse.omniture.getS()}if(s_code)document.write(s_code);if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-');</script><noscript><img src="//fusetv.112.2o7.net/b/ss/ftvfuse-prod/1/H.25.2--NS/0" height="1" width="1" border="0" alt=""></noscript><!-- /DO NOT REMOVE--><!-- End SiteCatalyst code version: H.25.2.--><script>var _gaq = _gaq || []; _gaq.push(['_setAccount', 'UA-28417629-1']); _gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();</script><!--Twitter Tracking Id--><script src="//platform.twitter.com/oct.js" type="text/javascript"></script><script type="text/javascript">twttr.conversion.trackPid('l4jhe');</script><noscript><img height="1" width="1" style="display:none;" alt="" src="https://analytics.twitter.com/i/adsct?txn_id=l4jhe&amp;p_id=Twitter"><img height="1" width="1" style="display:none;" alt="" src="//t.co/i/adsct?txn_id=l4jhe&amp;p_id=Twitter"></noscript><script>(function() { var cs = document.createElement('script'); cs.type = 'text/javascript'; cs.async = true; cs.src = ('https:' == document.location.protocol ? 'https://sb' : 'http://b') + '.scorecardresearch.com/beacon.js'; cs.onload = function() { COMSCORE.beacon({c1:"2", c2:"6035217", c3:"", c4:"", c5:"", c6:"", c15:""}); }; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(cs, s); })();</script><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=6035217&amp;cv=2.0&amp;cj=1" alt=""></noscript><script>(function() { var _fbq = window._fbq || (window._fbq = []); if (!_fbq.loaded) { var fbds = document.createElement('script'); fbds.async = true; fbds.src = '//connect.facebook.net/en_US/fbds.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(fbds, s); _fbq.loaded = true; }})(); window._fbq = window._fbq || []; window._fbq.push(['track', '6015605151051', {'value':'0.00','currency':'USD'}]);</script><noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?ev=6015605151051&amp;amp;cd[value]=0&amp;amp;cd[currency]=USD&amp;amp;noscript=1"></noscript><script type="text/javascript" async>window.twttr = (function (d,s,id) { var t, js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js=d.createElement(s); js.id=id; js.src="//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs); t = { _e: [], ready: function(f){ t._e.push(f) } }; return _.extend({}, (window.twttr || {}), t);}(document, "script", "twitter-wjs"));</script><script>twttr.ready(function(twttr){twttr.events.bind('tweet', fuse.analytics.trackTwitter);_.delay(function(){$('.content-tweet-container').css('visibility','visible')},500);});</script><script type="text/javascript">/* <![CDATA[ */
    var google_conversion_id = 953452828;
    var google_custom_params = window.google_tag_params;
    var google_remarketing_only = true;
/* ]]> */</script><script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js"></script><noscript><div style="display:inline;"><img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/953452828/?value=0&amp;guid=ON&amp;script=0"></div></noscript></body></html>