<!DOCTYPE html><html ng-strict-di><head><style>.async-hide {
    opacity: 0 !important
}</style><script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};(a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;})(window,document.documentElement,'async-hide','dataLayer',4000,{'GTM-TF3GS2Z':true});</script><script type="text/javascript">(function(d) {var config={kitId:'hgy3pat',scriptTimeout:10000}, h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement("script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";tk.src='//use.typekit.net/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)})(document);</script><link href="https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" rel="canonical"><link href="/css/10.27.0/main.min.css" rel="stylesheet" type="text/css"><link rel="icon" href="/images/favicon.png" type="image/png" sizes="16x16"><link rel="icon" href="/images/favicon.ico" type="image/x-icon"><link rel="shortcut icon" href="/images/favicon.ico" type="image/x-icon"><script>var _sf_startpt = (new Date()).getTime(); var fuse = {};var switchTo5x=true;fuse.pageContext = {"title":"'Cult of Chucky' Cast Talk Surprises, Coming 'Full Circle' 30 Years After 'Child's Play'","pageTitle":"'Cult of Chucky' Cast Talk New Surprises, Coming 'Full Circle' 30 Years After 'Child's Play'","shareTitle":"'Cult of Chucky' Cast Talk Surprises, Coming 'Full Circle' 30 Years After 'Child's Play'","description":"\"I think the fans are going to go crazy when they see this movie because there are a lot of characters from the past,\" actress Jennifer Tilly tells Fuse of the newest entry in the 'Child's Play' franchise.","keywords":"","twitterTracking":"","type":"video","contentType":"video","contributors":"Fuse Staff","image":"/image/59cd2029d62a49122b000045/560/292/social/sf00057-digi-001-am-cult-of-chucky-movie-1200x800-1057044035559.jpg","url":"https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent","path":"videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent","tags":["franchise:movies","franchise:interviews","miscellaneous:horror","franchise:news"],"opengraph":{"video":""},"published":"2017-09-28T20:56:00.000Z","lastModified":"2017-09-28T20:59:28.773Z","noIndexNoFollow":false,"showNewsletterSignup":false};</script><!-- Respond.js for IE8 support of HTML5 elements and media queries -->
<!--[if lt IE 9]><script src="/js/lib/10.27.0/respond.min.js" type="text/javascript"></script><![endif]--><!-- Start of Taboola Tags: do not remove--><script type="text/javascript">window._tfa = window._tfa || []; _tfa.push({notify:"action", name: 'page_view'});</script><script src="//cdn.taboola.com/libtrc/fusetv-sc/tfa.js"></script><!-- End of Taboola Tags: do not remove--><script src="//player.theplatform.com/pdk/_r8IPC/tpPdkController.js" type="text/javascript"></script><link href="//feeds.feedburner.com/fuse/latest" title="Latest from Fuse" rel="alternate" type="application/rss+xml"><title>'Cult of Chucky' Cast Talk New Surprises, Coming 'Full Circle' 30 Years After 'Child's Play' - Fuse</title><meta charset="utf-8"><meta name="apple-itunes-app" content="app-id=967013714"><meta name="google-play-app" content="app-id=com.fuse.fusetv"><meta http-equiv="content-type" content="text/html;charset=utf-8"><meta name="viewport" content="width=device-width,minimum-scale=1.0, maximum-scale=1.0, initial-scale=1.0"><meta name="description" content="&quot;I think the fans are going to go crazy when they see this movie because there are a lot of characters from the past,&quot; actress Jennifer Tilly tells Fuse of the newest entry in the 'Child's Play' franchise."><meta name="keywords" content=""><meta property="fb:pages" content="10262075277"><meta property="og:site_name" content="Fuse"><meta property="og:title" content="'Cult of Chucky' Cast Talk Surprises, Coming 'Full Circle' 30 Years After 'Child's Play'"><meta property="og:description" content="&quot;I think the fans are going to go crazy when they see this movie because there are a lot of characters from the past,&quot; actress Jennifer Tilly tells Fuse of the newest entry in the 'Child's Play' franchise."><meta property="og:image" content="https://www.fuse.tv/image/59cd2029d62a49122b000045/560/292/social/sf00057-digi-001-am-cult-of-chucky-movie-1200x800-1057044035559.jpg"><meta property="og:url" content="https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent"><meta property="og:type" content="video"><meta property="fb:app_id" content="1272603569472546"><meta property="fb:admins" content="741460474"><meta name="tpAccountId" content="_r8IPC"><meta name="tpPlayerIds" content="7JWSTWo6rV0z,TVdr9JLsj0qA"><meta name="tpPlayerHost" content="player.theplatform.com"><meta property="fw:profilePath" content="fuse_live"><meta property="fw:server" content="freewheel-live.fuse.tv"><meta property="fw:networkId" content="190200"><meta property="fw:adManagerServer" content="mssl.fwmrm.net"><!-- Facebook Pixel Code--><script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '858052264252640');fbq('track', 'PageView');</script><noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=858052264252640&amp;ev=PageView&amp;noscript=1"></noscript><!-- DO NOT MODIFY--><!-- End Facebook Pixel Code--></head><body itemscope itemtype="//schema.org/WebPage" class="video"><div class="container jp-container"><div class="row"><div class="col-span-24"><div class="header-ad"><div class="advert-outter"><div id="advert-leaderboard" class="advert-inner"></div></div></div></div></div></div><header itemscope itemtype="//schema.org/WPHeader" class="main-header"><div class="main-nav-container"><div class="container"><div class="row"><h1 data-section="header|logo" class="col-span-3 logo-container">FUSE<a href="/" data-track="item" class="icon-fuse-link"><div class="icon-fuse_logo"></div></a></h1><div class="col-span-15 nav-holder"><div class="row"><nav class="col-span-24"><ul data-section="header|nav" class="nav nav-main hidden-phone"><li class="nav-shows"><a href="/shows" data-track="item" data-track-title="shows" class="link-text">Shows</a></li><li class="nav-latest"><a href="/latest" data-track="item" data-track-title="latest" class="link-text">Latest</a></li><li class="nav-events"><a href="/events" data-track="item" data-track-title="events" class="link-text">Events</a></li><li class="nav-schedule"><a href="/schedule" data-track="item" data-track-title="tv schedule" class="link-text">Schedule</a></li></ul></nav></div></div><nav class="search-social-container"><ul class="search-social-nav"><li class="search-li"><a href="#" id="searchButton" class="icon-search"></a></li><li class="search-li"><a href="#" id="closeMobileMenu" class="icon-close_x close-mobile-menu"></a></li><li class="search-li"><a href="#" id="burgerButton" class="visible-phone icon-menu"></a></li><li class="search-li"><a href="#" id="moreButton" class="icon-three_dots"></a></li></ul><div id="searchBoxContainer" class="search-box"><fieldset id="search-box"><button type="button" for="fuse-search-field" class="search-label"><div class="icon-search icon-desktop"><i></i></div></button><label for="fuse-search-field" class="search-close-label"><div class="icon-close_x"><i></i></div></label><input type="text" id="fuse-search-field" name="q" placeholder="" class="search-input"></fieldset></div></nav><a id="jump" href="http://www.fm.tv" data-track="fusefm" data-track-title="fusefm" class="jump-to-fm visible-desktop"><span class="visible-desktop icon-fusefm_logo"><i></i></span><span class="visible-desktop jump-to-text">Jump to FM.tv</span></a></div></div></div><div class="container"><div class="more-arrow hidden"></div><div id="nav-wrapper" class="more-box"><ul data-section="header|nav" class="nav nav-main visible-phone"><li class="nav-shows"><a href="/shows" data-track="item" data-track-title="shows" class="link-text">Shows</a></li><li class="nav-latest"><a href="/latest" data-track="item" data-track-title="latest" class="link-text">Latest</a></li><li class="nav-events"><a href="/events" data-track="item" data-track-title="events" class="link-text">Events</a></li><li class="nav-schedule"><a href="/schedule" data-track="item" data-track-title="tv schedule" class="link-text">Schedule</a></li><li class="divider"></li></ul><div class="col-span-17 nav-social"><a href="//facebook.com/Fuse" target="_blank" data-track="item" data-track-title="facebook" class="nav-social__icon nav-social__icon--facebook-white"><i></i></a><a href="//twitter.com/fusetv" target="_blank" data-track="item" data-track-title="twitter" class="nav-social__icon nav-social__icon--twitter-white"><i></i></a><a href="//youtube.com/fuse" target="_blank" data-track="item" data-track-title="youtube" class="nav-social__icon nav-social__icon--youtube"><i></i></a><a href="//instagram.com/fusetv" target="_blank" data-track="item" data-track-title="youtube" class="nav-social__icon nav-social__icon--instagram"><i></i></a></div><nav class="col-span-24"><div class="divider"></div><ul class="ext-nav"><li class="ext-nav-li"><a href="/privacy-policy" data-track="item" class="ext-nav-link">Privacy Policy</a></li><li class="ext-divider">-</li><li class="ext-nav-li"><a href="/terms-of-use" data-track="item" class="ext-nav-link">Terms of Use</a></li><li class="ext-divider">-</li><li class="ext-nav-li"><a href="/closed-captioning" data-track="item" class="ext-nav-link">Closed Captioning</a></li><li class="ext-divider"></li><li class="ext-nav-li"><a href="/about-fuse" data-track="item" class="ext-nav-link">About Fuse</a></li><li class="ext-divider">-</li><li class="ext-nav-li"><a href="/press" data-track="item" class="ext-nav-link">Press</a></li></ul></nav><div class="col-span-24 copyright">&copy; 2017 FUSE, LLC. ALL RIGHTS RESERVED.</div></div><a id="fmButton" href="http://www.fm.tv" data-track="fusefm" data-track-title="fusefm" class="jump-to-fm hidden-desktop"><span class="icon-fusefm_logo"><i></i></span><span class="jump-to-text">Jump to FM.tv</span></a></div><div class="row visible-desktop topics"><div class="container"><ul data-section="header|topic" class="nav-topic-list"><li class="nav-topic-li"><strong class="nav-topic-strong">Don't Miss:</strong></li><li class="nav-topic-li"><a href="/shows/big-freedia" data-track="item" class="nav-topic-link">Big Freedia Bounces Back</a></li><li class="divider"></li><li class="nav-topic-li"><a href="/shows/future-hispanic-history" data-track="item" class="nav-topic-link">Future Hispanic History</a></li><li class="divider"></li><li class="nav-topic-li"><a href="https://www.globalgiving.org/fuse-cares/" data-track="item" class="nav-topic-link">Fuse Disaster Relief: Help Here</a></li><li class="divider"></li><li class="nav-topic-li"><a href="http://www.fuse.tv/tags/interviews" data-track="item" class="nav-topic-link">Interviews</a></li><li class="divider"></li><li class="nav-topic-li"><a href="http://www.fuse.tv/tags/lists" data-track="item" class="nav-topic-link">Lists</a></li></ul></div></div></header><div class="background-image-container background-image-container--video"></div><div id="menu-overlay" class="menu-overlay"></div><div class="container main-container two-columns-layout video-page-type"><div class="row two-columns"><div class="col-span-17 video-page-content js-has-the-platform-video"><div class="content-header"><div class="rubric">Interview</div><h1 itemprop="name" class="article-title">'Cult of Chucky' Cast Talk Surprises, Coming 'Full Circle' 30 Years After 'Child's Play'</h1><div itemprop="description" class="dek">&quot;I think the fans are going to go crazy when they see this movie because there are a lot of characters from the past,&quot; actress Jennifer Tilly tells Fuse</div></div><div class="content-sub-header"><div data-section="center|contributors" class="contributors-info"><ul class="contributors-list"><li class="contributors-item"><a href="/contributors/fuse-staff" rel="author" data-track="contributor" data-track-title="fuse-staff" class="contributors-link"><span>Fuse Staff</span></a></li></ul><span datetime="2017-09-28T08:56:00+00:00" itemprop="datePublished" class="published">September 28, 2017</span></div><div class="social-container top"><div data-section="center|share" class="share-container"><div id="result"></div><ul class="share-list"><li class="item"><a data-track-title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" target="_blank" class="item-container share-tracker js-share-btn__facebook"><span class="icon icon-facebook"></span><span class="text">share</span></a><span class="bubble-count fb-count">0</span></li><li class="item"><a data-track-title="twitter" href="https://twitter.com/intent/tweet?text=&amp;via=fusetv&amp;url=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" target="_blank" class="item-container share-tracker js-share-btn__twitter"><span class="icon icon-twitter"></span><span class="text">tweet</span></a></li><li class="item"><a data-track-title="tumblr" href="https://www.tumblr.com/share/link?url=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" target="_blank" class="item-container share-tracker last js-share-btn__tumblr"><span class="icon icon-tumblr"></span><span class="text">share</span></a><span class="bubble-count tumb-count">0</span></li><li class="item more-share icon-plus"></li></ul><ul class="more-share-items">&nbsp;<li class="item"><a data-track-title="reddit" href="https://www.reddit.com/submit?url=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent&amp;title=" target="_blank" class="item-container share-tracker js-share-btn__reddit"><span class="icon icon-redit_face"></span><span class="text">share</span></a><span class="bubble-count red-count">0</span></li><li class="item"><a data-track-title="google" href="https://plus.google.com/share?url=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" target="_blank" class="item-container share-tracker js-share-btn__gplus"><span class="icon icon-google"></span><span class="text">share</span></a><span class="bubble-count glg-count">0</span></li><li class="item"><a data-track-title="pinterest" href="https://pinterest.com/pin/create/button/?url=&quot;https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent&amp;media=https://www.fuse.tv/image/59cd2029d62a49122b000045/560/292/social/sf00057-digi-001-am-cult-of-chucky-movie-1200x800-1057044035559.jpg&amp;description=&quot;" target="_blank" class="item-container share-tracker js-share-btn__pinterest"><span class="icon icon-pinterest"></span><span class="text">pin it</span></a><span class="bubble-count ptr-count">0</span></li></ul></div></div><div class="social-container side"><div data-section="left|share" class="share-side"><div class="share-side-buttons visible-desktop"><div id="result"></div><ul class="share-list"><li class="item"><a data-track-title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" target="_blank" class="item-container share-tracker js-share-btn__facebook"><span class="icon icon-facebook"></span><span class="text">share</span></a><span class="bubble-count fb-count">0</span></li><li class="item"><a data-track-title="twitter" href="https://twitter.com/intent/tweet?text=&amp;via=fusetv&amp;url=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" target="_blank" class="item-container share-tracker js-share-btn__twitter"><span class="icon icon-twitter"></span><span class="text">tweet</span></a></li><li class="item"><a data-track-title="tumblr" href="https://www.tumblr.com/share/link?url=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" target="_blank" class="item-container share-tracker last js-share-btn__tumblr"><span class="icon icon-tumblr"></span><span class="text">share</span></a><span class="bubble-count tumb-count">0</span></li><li class="item more-share icon-plus"></li></ul><ul class="more-share-items">&nbsp;<li class="item"><a data-track-title="reddit" href="https://www.reddit.com/submit?url=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent&amp;title=" target="_blank" class="item-container share-tracker js-share-btn__reddit"><span class="icon icon-redit_face"></span><span class="text">share</span></a><span class="bubble-count red-count">0</span></li><li class="item"><a data-track-title="google" href="https://plus.google.com/share?url=https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" target="_blank" class="item-container share-tracker js-share-btn__gplus"><span class="icon icon-google"></span><span class="text">share</span></a><span class="bubble-count glg-count">0</span></li><li class="item"><a data-track-title="pinterest" href="https://pinterest.com/pin/create/button/?url=&quot;https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent&amp;media=https://www.fuse.tv/image/59cd2029d62a49122b000045/560/292/social/sf00057-digi-001-am-cult-of-chucky-movie-1200x800-1057044035559.jpg&amp;description=&quot;" target="_blank" class="item-container share-tracker js-share-btn__pinterest"><span class="icon icon-pinterest"></span><span class="text">pin it</span></a><span class="bubble-count ptr-count">0</span></li></ul></div></div></div></div><div class="content-container"><div class="video-page"><div id="js-player-container_59cd29b91156f5bc2b00004d" data-player-id="7JWSTWo6rV0z" data-type="theplatform" data-autoplay="true" data-has-bug="true" data-src="m7qejkikT31I" data-player-scope="scope_59cd29b91156f5bc2b00004d" data-asset-type="playlist" class="c-the-platform js-the-platform automation-content__thePlatform c-the-platform--video-page js-is-default-player"><iframe id="js-scope_59cd29b91156f5bc2b00004d" src="//player.theplatform.com/p/_r8IPC/7JWSTWo6rV0z/feed/m7qejkikT31I/select/media/k4UK9QdZmsOr?form=html&amp;instance=scope_59cd29b91156f5bc2b00004d&amp;autoPlay=false" seamless="seamless" frameBorder="0" allowFullScreen="allowFullScreen" class="c-the-platform__iframe js-the-platform__iframe"></iframe></div><div class="text automation-content__text"><p>With everyone's favorite killer doll officially returning October 3, Fuse sat down with the exciting cast of&nbsp;<em>Cult of Chucky </em>to discuss the film's surprises, fan reactions, and bringing back some of the franchise's beloved characters.</p><p>"I think the fans are going to go crazy when they see this movie because there are a lot of characters from the past," Jennifer Tilly explains, specifically shouting out Alex Vincent's highly anticipated reprisal of Andy Barclay, whom he portrayed&nbsp;nearly three decades ago in <em>Child's Play.</em></p></div><div class="row visible-phone"><div data-ad-id="ad_videoTop_phone" class="ad-top-phone"></div></div><div class="related-content-plug automation-content__relatedPage"><div><span class="more">More:</span><span><a href="/2013/10/13-creepiest-horror-movie-themes"><span>13 Creepiest Horror Movie Themes</span></a></span></div></div><div class="text automation-content__text"><p>"I think fans enjoy the fact that [Andy's] still around 30 years later...and kind of wanted to see this story take that full-circle approach," Vincent adds.</p><p>Tilly also dived into the complexities of her reprised character, Tiffany, an individual she described as "easily relatable" despite being a serial murderer. "I think there's something a little bit lovable about her," she tells Fuse.</p><p>Next, Fiona Dourif says it's "truly scary" acting opposite her father's voice as Chucky:</p></div><div id="js-player-container_59cd29cc1156f5bc2b00004f" data-player-id="7JWSTWo6rV0z" data-type="theplatform" data-autoplay="false" data-has-bug="true" data-src="m7qejkikT31I" data-player-scope="scope_59cd29cc1156f5bc2b00004f" data-asset-type="playlist" class="c-the-platform js-the-platform automation-content__thePlatform c-the-platform--video-page js-is-default-player"><iframe id="js-scope_59cd29cc1156f5bc2b00004f" src="//player.theplatform.com/p/_r8IPC/7JWSTWo6rV0z/feed/m7qejkikT31I/select/media/3OnW7CdcvXAO?form=html&amp;instance=scope_59cd29cc1156f5bc2b00004f&amp;autoPlay=false" seamless="seamless" frameBorder="0" allowFullScreen="allowFullScreen" class="c-the-platform__iframe js-the-platform__iframe"></iframe></div><div class="text automation-content__text"><p>For more <em>Chucky</em> goodness, watch special effects guru Tony Gardner give us a rundown of the evolution of the Chucky animatronic doll through the series:</p></div><div id="js-player-container_59cd29c9d62a49122b000060" data-player-id="7JWSTWo6rV0z" data-type="theplatform" data-autoplay="false" data-has-bug="true" data-src="m7qejkikT31I" data-player-scope="scope_59cd29c9d62a49122b000060" data-asset-type="playlist" class="c-the-platform js-the-platform automation-content__thePlatform c-the-platform--video-page js-is-default-player"><iframe id="js-scope_59cd29c9d62a49122b000060" src="//player.theplatform.com/p/_r8IPC/7JWSTWo6rV0z/feed/m7qejkikT31I/select/media/phbfCh6tA4NU?form=html&amp;instance=scope_59cd29c9d62a49122b000060&amp;autoPlay=false" seamless="seamless" frameBorder="0" allowFullScreen="allowFullScreen" class="c-the-platform__iframe js-the-platform__iframe"></iframe></div></div><div data-section="center|tags" class="compnt compnt-tags"><div class="compnt-content automation_tags"><strong class="tags-title">Tags:&nbsp;</strong><a href="/tags/movies" data-track="item" rel="tag" class="tag-link automation-tags__tag">Movies</a><span>,&nbsp;</span><a href="/tags/interviews" data-track="item" rel="tag" class="tag-link automation-tags__tag">Interviews</a><span>,&nbsp;</span><a href="/tags/horror" data-track="item" rel="tag" class="tag-link automation-tags__tag">Horror</a><span>,&nbsp;</span><a href="/tags/news" data-track="item" rel="tag" class="tag-link automation-tags__tag">News</a></div></div><div data-section="center|prev-next" class="compnt compnt-prev-next clearfix"><div class="prev"><a href="/videos/2017/09/cult-of-chucky-fionna-dourif-interview-brad-dourif-chucky-voice" data-track="prev-arrow" class="icon-arrow icon-arrow_left"></a><p class="text"><a href="/videos/2017/09/cult-of-chucky-fionna-dourif-interview-brad-dourif-chucky-voice" data-track="prev-title" class="link"> <span class="nav-name">PREVIOUS</span><span class="nav-text">Growing Up With Chucky: 'Cult of Chucky' Star Fiona Dourif on Her Dad Voicing Chucky</span></a></p></div><div class="next"><a href="/videos/2017/09/cult-of-chucky-cast-crew-talk-chucky-doll-evolution-childs-play" data-track="next-arrow" class="icon-arrow icon-arrow_right"></a><p class="text"><a href="/videos/2017/09/cult-of-chucky-cast-crew-talk-chucky-doll-evolution-childs-play" data-track="next-title" class="link"> <span class="nav-name">NEXT </span><span class="nav-text">'Cult of Chucky' Cast Talk Chucky's Evolution Over the Years</span></a></p></div></div><div class="row"><div class="col-span-26"><div data-section="center|recommended" class="compnt module compnt-zergnet"><div class="compnt-content"><div id="zergnet-widget-46079" class="row"></div><div id="zergnet-widget-46081" class="row"></div></div></div></div></div><div class="row visible-phone"><div id="ad_articleBottom_phone" class="ad-bottom-phone"></div></div></div><div class="user-comments"><div class="compnt module"><div class="compnt-head"><h3 class="title border">User Comments</h3></div><div data-width="716" data-href="https://www.fuse.tv/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" class="fb-comments"></div></div><div id="ad_videoBottom_tablet" class="visible-tablet ad-bottom-tablet"></div></div><div id="newsLetter_mobile" class="col-span-24 newsLetter"><div id="newsLetterModule" class="compnt module"><div class="compnt-head"><h3 class="titleRow"><span class="calReplyTitle">Fuse NewsLetter</span></h3></div><div class="compnt-content newsletter"><p class="calReplyCopy">Keep up to date with the latest news by subscribing to our newsletter.</p><span class="asteriskText"><span class="asteriskRequired">*</span><span>required</span></span><link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css"/><div id="mc_embed_signup" class="signup"><form action="//fuse.us13.list-manage.com/subscribe/post?u=e15fce9d938435f15fa2d4ab6&amp;amp;id=40f770dac6" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank" novalidate="novalidate" class="validate"><div id="mc_embed_signup_scroll" class="scroll"><div class="mc-field-group"><label for="mce-EMAIL" class="subtitle">Email Address&nbsp;</label><span class="asterisk">*</span><input type="email" value="" name="EMAIL" id="mce-EMAIL" class="required newsLetterField"/></div><div class="mc-field-group"><label for="mce-FNAME" class="subtitle">First Name&nbsp;</label><span class="asterisk">*</span><input type="text" value="" name="FNAME" id="mce-FNAME" class="required newsLetterField"/></div><div class="mc-field-group"><label for="mce-LNAME" class="subtitle">Last Name&nbsp;</label><span class="asterisk">*</span><input type="text" value="" name="LNAME" id="mce-LNAME" class="required newsLetterField"/></div><div class="mc-field-group"><label for="mce-MMERGE3" class="subtitle">Zip Code&nbsp;</label><span class="asterisk">*</span><input type="text" value="" name="MMERGE3" id="mce-MMERGE3" class="required newsLetterField"/></div><div class="mc-field-group size1of2"><label for="mce-MMERGE4-month">Birthdate</label><div class="datefield"><span class="subfield monthfield"><input type="text" pattern="[0-9]*" value="" placeholder="MM" size="2" maxlength="2" name="MMERGE4[month]" id="mce-MMERGE4-month" class="datepart monthField"/></span><span class="subfield dayfield"><input type="text" pattern="[0-9]*" value="" placeholder="DD" size="2" maxlength="2" name="MMERGE4[day]" id="mce-MMERGE4-day" class="datepart "/></span><span class="subfield yearfield"><input type="text" pattern="[0-9]*" value="" placeholder="YYYY" size="4" maxlength="4" name="MMERGE4[year]" id="mce-MMERGE4-year" class="datepart "/></span><span class="small-meta nowrap">( mm / dd / yyyy )</span></div></div><div id="mce-responses" class="clear"><div id="mce-error-response" style="display:none" class="response"></div><div id="mce-success-response" style="display:none" class="response"></div></div><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_e15fce9d938435f15fa2d4ab6_40f770dac6" tabindex="-1" value=""/></div><div class="clear submitBtn"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button subscribe-btn"/></div></div></form></div><script type="text/javascript" src="//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js"></script><script type="text/javascript">- function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';}(jQuery);var $mcj = jQuery.noConflict(true);
</script></div></div></div></div><div class="col-span-7 hidden-tablet hidden-phone"><div class="mrg-top-15"><div class="ad text-center"><span style="margin:0px auto;overflow:hidden;" id="ad_videoTop" class="advert _fwph"><form id="_fw_form_ad_videoTop" style="display:none;"><input type="hidden" name="_fw_input_ad_videoTop" id="_fw_input_ad_videoTop" value="ptgt=s&amp;w=300&amp;h=250&amp;slid=ad_videoTop&amp;cd=300,250|300,600&amp;slau="/></form><span id="_fw_container_ad_videoTop"></span></span><span class="ad">Advertisement</span></div></div><div id="newsLetter-container"></div><div class="mrg-top-10"><div data-limit="5" data-section="right|recommended" class="compnt module compnt-popular list-sidebar"><div class="compnt-head"><h3>Recommended</h3></div><ul class="unstyled"><li class="recommended-item"><a href="/videos/2017/09/cult-of-chucky-cast-crew-talk-chucky-doll-evolution-childs-play" data-track="item" class="recommended-link"><span class="recommended-image-holder"><img src="/image/59cd5fe1c3714e112b0000a2/124/83/crop/doll-cult-of-chucky-still-2.jpg" title="Doll - Cult of Chucky - Still 2" width="124" height="83"/><span class="icon-play_icon"></span></span><span class="description"><span class="rubric">Interview</span><h3 class="recommended-title">'Cult of Chucky' Cast Talk Chucky's Evolution Over the Years</h3></span></a></li><li class="recommended-item"><a href="/videos/2017/09/cult-of-chucky-fionna-dourif-interview-brad-dourif-chucky-voice" data-track="item" class="recommended-link"><span class="recommended-image-holder"><img src="/image/59cd5c9fc3714e112b00009c/124/83/crop/family-business-cult-of-chucky-still-2.jpg" title="Family Business - Cult of Chucky - Still 2" width="124" height="83"/><span class="icon-play_icon"></span></span><span class="description"><span class="rubric">Interview</span><h3 class="recommended-title">Growing Up With Chucky: 'Cult of Chucky' Star Fiona Dourif on Her Dad Voicing Chucky</h3></span></a></li><li class="recommended-item"><a href="/videos/2017/09/celebrities-who-love-bts" data-track="item" class="recommended-link"><span class="recommended-image-holder"><img src="/image/59bbeecd66c19e0d3e000053/124/83/crop/5-celebrities-who-love-bts-updated-still.jpg" title="5 Celebrities Who Love BTS UPDATED - Still" width="124" height="83"/><span class="icon-play_icon"></span></span><span class="description"><span class="rubric">List</span><h3 class="recommended-title">15 Celebrities Who Love BTS</h3></span></a></li><li class="recommended-item"><a href="/videos/2017/09/future-hispanic-history-month-melanie-martinez-tattoos" data-track="item" class="recommended-link"><span class="recommended-image-holder"><img src="/image/59cbd756bd86aebb2b000026/124/83/crop/melanie-martinez-fhhm-still.jpg" title="Melanie Martinez - FHHM - Still" width="124" height="83"/><span class="icon-play_icon"></span></span><span class="description"><span class="rubric">Spotlight</span><h3 class="recommended-title">Future Hispanic History: Tattoo Storytelling With Melanie Martinez</h3></span></a></li><li class="recommended-item"><a href="/videos/2017/09/tbt-2013-the-dream-iv-play-album" data-track="item" class="recommended-link"><span class="recommended-image-holder"><img src="/image/59cbfe0ec3714e112b00002e/124/83/crop/the-dream-tbt-still.jpg" title="The Dream - TBT - Still" width="124" height="83"/><span class="icon-play_icon"></span></span><span class="description"><span class="rubric">Fuse Original</span><h3 class="recommended-title">#TBT 2013: The-Dream Calls 'IV Play' the 'Most Intelligent, Ratchetest' R&amp;B Album</h3></span></a></li></ul></div></div><div class="mrg-top-30 mrg-btm-40"><div class="ad text-center"><span style="margin:0px auto;overflow:hidden;" id="ad_videoBottom" class="advert _fwph"><form id="_fw_form_ad_videoBottom" style="display:none;"><input type="hidden" name="_fw_input_ad_videoBottom" id="_fw_input_ad_videoBottom" value="ptgt=s&amp;w=300&amp;h=250&amp;slid=ad_videoBottom&amp;cd=300,250&amp;slau=300x250bottom"/></form><span id="_fw_container_ad_videoBottom"></span></span><span class="ad">Advertisement</span></div></div></div></div><div id="latest" class="row"><div class="col-span-24 latest-block latest-block-ipad"><div data-feature-filter="genre" data-section="bottom|latest" class="compnt section compnt-latest"><div class="compnt-head blue-title"><h3 class="module-subtitle">The Latest</h3></div><div class="compnt-content"><div class="latest-container"><div class="col-span-6 feature-quarter"><a href="/videos/2017/09/cult-of-chucky-cast-crew-talk-chucky-doll-evolution-childs-play" data-track="item" class="img"><img src="/image/59cd5fe1c3714e112b0000a2/268/179/crop/doll-cult-of-chucky-still-2.jpg" title="Doll - Cult of Chucky - Still 2" width="268" height="179" class="stream-image"/><span class="rubric">Interview</span><div class="icon-play_icon"></div></a><div class="title-description"><a href="/videos/2017/09/cult-of-chucky-cast-crew-talk-chucky-doll-evolution-childs-play" data-track="item"><h2 class="stream-title">'Cult of Chucky' Cast Talk Chucky's Evolution Over the Years</h2></a><div class="date-user gray-letters"><a href="/contributors/fuse-staff" rel="author" data-track="contributor" class="user-link"><span>Fuse Staff</span><span>&nbsp;/ September 28, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter middleMargins"><a href="/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" data-track="item" class="img"><img src="/image/59cd2029d62a49122b000045/268/179/crop/movie-cult-of-chucky-still.jpg" title="Movie - Cult of Chucky - Still" width="268" height="179" class="stream-image"/><span class="rubric">Interview</span><div class="icon-play_icon"></div></a><div class="title-description"><a href="/videos/2017/09/cult-of-chucky-cast-interview-jennifer-tilly-don-mancini-alex-vincent" data-track="item"><h2 class="stream-title">'Cult of Chucky' Cast Talk New Surprises, Coming 'Full Circle' 30 Years Later</h2></a><div class="date-user gray-letters"><a href="/contributors/fuse-staff" rel="author" data-track="contributor" class="user-link"><span>Fuse Staff</span><span>&nbsp;/ September 28, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/videos/2017/09/cult-of-chucky-fionna-dourif-interview-brad-dourif-chucky-voice" data-track="item" class="img"><img src="/image/59cd5c9fc3714e112b00009c/268/179/crop/family-business-cult-of-chucky-still-2.jpg" title="Family Business - Cult of Chucky - Still 2" width="268" height="179" class="stream-image"/><span class="rubric">Interview</span><div class="icon-play_icon"></div></a><div class="title-description"><a href="/videos/2017/09/cult-of-chucky-fionna-dourif-interview-brad-dourif-chucky-voice" data-track="item"><h2 class="stream-title">Growing Up With Chucky: 'Cult of Chucky' Star Fiona Dourif on Her Dad Voicing Chucky</h2></a><div class="date-user gray-letters"><a href="/contributors/fuse-staff" rel="author" data-track="contributor" class="user-link"><span>Fuse Staff</span><span>&nbsp;/ September 28, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/videos/2017/09/celebrities-who-love-bts" data-track="item" class="img"><img src="/image/59bbeecd66c19e0d3e000053/268/179/crop/5-celebrities-who-love-bts-updated-still.jpg" title="5 Celebrities Who Love BTS UPDATED - Still" width="268" height="179" class="stream-image"/><span class="rubric">List</span><div class="icon-play_icon"></div></a><div class="title-description"><a href="/videos/2017/09/celebrities-who-love-bts" data-track="item"><h2 class="stream-title">15 Celebrities Who Love BTS</h2></a><div class="date-user gray-letters"><a href="/contributors/fuse-staff" rel="author" data-track="contributor" class="user-link"><span>Fuse Staff</span><span>&nbsp;/ September 28, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter middleMargins"><a href="/2017/09/hocus-pocus-tv-movie-remake-disney-channel" data-track="item" class="img"><img src="/image/59cd0d8ebd86aebb2b00009c/268/179/crop/hocus-pocus-still.jpg" title="Hocus Pocus - Still" width="268" height="179" class="stream-image"/><span class="rubric">WHY</span></a><div class="title-description"><a href="/2017/09/hocus-pocus-tv-movie-remake-disney-channel" data-track="item"><h2 class="stream-title">A 'Hocus Pocus' TV Movie Remake Is In The Works...</h2></a><div class="date-user gray-letters"><a href="/contributors/bianca-gracie" rel="author" data-track="contributor" class="user-link"><span>Bianca Gracie</span><span>&nbsp;/ September 28, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/2017/09/pink-beautiful-trama-title-track-stream" data-track="item" class="img"><img src="/image/59cd0a5cbd86aebb2b000094/268/179/crop/pink-2017-mtv-video-music-awards-show.jpg" title="Pink 2017 MTV Video Music Awards - Show" alt="INGLEWOOD, CA - AUGUST 27:  Pink performs during the 2017 MTV Video Music Awards at The Forum on August 27, 2017 in Inglewood" width="268" height="179" class="stream-image"/><span class="rubric">Hot Song</span></a><div class="title-description"><a href="/2017/09/pink-beautiful-trama-title-track-stream" data-track="item"><h2 class="stream-title">Hear Pink's Destructive 'Beautiful Trama' Title Track</h2></a><div class="date-user gray-letters"><a href="/contributors/bianca-gracie" rel="author" data-track="contributor" class="user-link"><span>Bianca Gracie</span><span>&nbsp;/ September 28, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter"><a href="/videos/2017/09/future-hispanic-history-month-melanie-martinez-tattoos" data-track="item" class="img"><img src="/image/59cbd756bd86aebb2b000026/268/179/crop/melanie-martinez-fhhm-still.jpg" title="Melanie Martinez - FHHM - Still" width="268" height="179" class="stream-image"/><span class="rubric">Spotlight</span><div class="icon-play_icon"></div></a><div class="title-description"><a href="/videos/2017/09/future-hispanic-history-month-melanie-martinez-tattoos" data-track="item"><h2 class="stream-title">Future Hispanic History: Tattoo Storytelling With Melanie Martinez</h2></a><div class="date-user gray-letters"><a href="/contributors/fuse-staff" rel="author" data-track="contributor" class="user-link"><span>Fuse Staff</span><span>&nbsp;/ September 28, 2017</span></a></div></div></div><div class="col-span-6 feature-quarter middleMargins"><a href="/videos/2017/09/tbt-2013-the-dream-iv-play-album" data-track="item" class="img"><img src="/image/59cbfe0ec3714e112b00002e/268/179/crop/the-dream-tbt-still.jpg" title="The Dream - TBT - Still" width="268" height="179" class="stream-image"/><span class="rubric">Fuse Original</span><div class="icon-play_icon"></div></a><div class="title-description"><a href="/videos/2017/09/tbt-2013-the-dream-iv-play-album" data-track="item"><h2 class="stream-title">#TBT 2013: The-Dream Calls 'IV Play' the 'Most Intelligent, Ratchetest' R&amp;B Album</h2></a><div class="date-user gray-letters"><a href="/contributors/fuse-staff" rel="author" data-track="contributor" class="user-link"><span>Fuse Staff</span><span>&nbsp;/ September 28, 2017</span></a></div></div></div></div></div><div class="compnt-foot"><div class="load-img hide-all"></div><a href="#" data-stream="/content/stream/latest?page=2" data-append-to=".latest-container" data-item-selector=".feature-quarter" data-limit="8" data-track="more" class="square-btn load-stream">Load More</a></div></div></div></div></div><footer itemscope itemtype="https://schema.org/WPFooter" class="hidden-phone hidden-tablet main-footer"><div class="container"><div class="footer-links hidden-phone"><div class="col-span-3"><a href="/" data-track="item" class="icon-fuse-link"><div class="icon-fuse_logo"></div></a></div><div class="col-span-17"><div class="row"><ul data-section="footer|nav" class="nav nav-main"><li class="nav-shows"><a href="/shows" data-track="item" data-track-title="shows" class="link-text">Shows</a></li><li class="nav-latest"><a href="/latest" data-track="item" data-track-title="latest" class="link-text">Latest</a></li><li class="nav-events"><a href="/events" data-track="item" data-track-title="events" class="link-text">Events</a></li><li class="nav-schedule"><a href="/schedule" data-track="item" data-track-title="tv schedule" class="link-text">Schedule</a></li></ul></div></div><div class="col-span-4"><div data-track="footer|social" class="compnt right"><div class="compnt-content nav-social"><a href="//facebook.com/Fuse" target="_blank" data-track="item" data-track-title="facebook" class="nav-social__icon nav-social__icon--facebook-white"><i></i></a><a href="//twitter.com/fusetv" target="_blank" data-track="item" data-track-title="twitter" class="nav-social__icon nav-social__icon--twitter-white"><i></i></a><a href="//youtube.com/fuse" target="_blank" data-track="item" data-track-title="youtube" class="nav-social__icon nav-social__icon--youtube"><i></i></a><a href="//instagram.com/fusetv" target="_blank" data-track="item" data-track-title="youtube" class="nav-social__icon nav-social__icon--instagram"><i></i></a></div></div></div></div><div class="row"><div class="col-span-24"><ul class="ext-nav"><li class="ext-nav-li"><a href="/privacy-policy" data-track="item" class="ext-nav-link">Privacy Policy</a></li><li class="divider"></li><li class="ext-nav-li"><a href="/terms-of-use" data-track="item" class="ext-nav-link">Terms of Use</a></li><li class="divider"></li><li class="ext-nav-li"><a href="/closed-captioning" data-track="item" class="ext-nav-link">Closed Captioning</a></li><li class="divider"></li><li class="ext-nav-li"><a href="/about-fuse" data-track="item" class="ext-nav-link">About Fuse</a></li><li class="divider"></li><li class="ext-nav-li"><a href="/press" data-track="item" class="ext-nav-link">Press</a></li></ul></div><div class="col-span-24 copyright">&copy; 2017 FUSE, LLC. ALL RIGHTS RESERVED.</div></div></div></footer><div id="fb-root"></div><div id="BF_WIDGET_1"></div><script src="/js/10.27.0/base.min.js"></script><script src="/js/10.27.0/fuse.ui.tvschedule.min.js"></script><script>window.fbAsyncInit = function(){FB.init({appId:'1272603569472546',version:'v2.8',cookie:true,status:true,xfbml:true,channelUrl:'//www.fuse.tv/channel.html'});fuse.analytics.trackFacebook();if(fuse.fbAsyncInit){fuse.fbAsyncInit();}};</script><script>(function(d, s, id){var js, fjs = d.getElementsByTagName(s)[0];if (d.getElementById(id)) {return;}js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/sdk.js";fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));</script><script src="//platform.instagram.com/en_US/embeds.js" async="" defer=""></script><!-- SiteCatalyst code version: H.25.2. Copyright 1996-2012 Adobe, Inc. All Rights Reserved More info available at http://www.omniture.com--><script src="/js/10.27.0/fuse.tracking.min.js"></script><script>var s_code = null;fuse.omniture.initPageData();if (fuse.omniture.isTrackPageViewAutomaticallyEnable()){s_code=s.t();}else{s=fuse.omniture.getS()}if(s_code)document.write(s_code);if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-');</script><noscript><img src="//fusetv.112.2o7.net/b/ss/ftvfuse-prod/1/H.25.2--NS/0" height="1" width="1" border="0" alt=""></noscript><!-- /DO NOT REMOVE--><!-- End SiteCatalyst code version: H.25.2.--><!-- Google Analytics--><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-28417629-1', 'auto'); ga('require', 'GTM-TF3GS2Z');ga('send', 'pageview');</script><!--Twitter Tracking Id--><script src="//platform.twitter.com/oct.js" type="text/javascript"></script><script type="text/javascript">twttr.conversion.trackPid('l4jhe');</script><noscript><img height="1" width="1" style="display:none;" alt="" src="https://analytics.twitter.com/i/adsct?txn_id=l4jhe&amp;p_id=Twitter"><img height="1" width="1" style="display:none;" alt="" src="//t.co/i/adsct?txn_id=l4jhe&amp;p_id=Twitter"></noscript><script>(function() { var cs = document.createElement('script'); cs.type = 'text/javascript'; cs.async = true; cs.src = 'https://sb' + '.scorecardresearch.com/beacon.js'; cs.onload = function() { COMSCORE.beacon({c1:"2", c2:"6035217", c3:"", c4:"", c5:"", c6:"", c15:""}); }; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(cs, s); })();</script><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=6035217&amp;cv=2.0&amp;cj=1" alt=""></noscript><script type="text/javascript" async>window.twttr = (function (d,s,id) { var t, js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js=d.createElement(s); js.id=id; js.src="//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs); t = { _e: [], ready: function(f){ t._e.push(f) } }; return _.extend({}, (window.twttr || {}), t);}(document, "script", "twitter-wjs"));</script><script>twttr.ready(function(twttr){twttr.events.bind('tweet', fuse.analytics.trackTwitter);_.delay(function(){$('.content-tweet-container').css('visibility','visible')},500);});</script><script type="text/javascript">/* <![CDATA[ */
    var google_conversion_id = 953452828;
    var google_custom_params = window.google_tag_params;
    var google_remarketing_only = true;
/* ]]> */</script><script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js"></script><noscript><div style="display:inline;"><img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/953452828/?value=0&amp;guid=ON&amp;script=0"></div></noscript></body></html>